# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^,]*,(\d\d)_[^,]*,[^,]*)(?<!_\d\d),/$1_$2,/gms;t' <<< "test,12_blah,blubb,anything
test,34_blah,blu_34,doesn't matter
test,56_foo,bar,nevermind"