#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)^([^,]*,(\d\d)_[^,]*,[^,]*)(?<!_\d\d),"
Local $sString = "test,12_blah,blubb,anything" & @CRLF & _
"test,34_blah,blu_34,doesn't matter" & @CRLF & _
"test,56_foo,bar,nevermind"
Local $sSubst = "$1_$2,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)