# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^,]*,(\d\d)_[^,]*,[^,]*)(?<!_\d\d),"
test_str = ("test,12_blah,blubb,anything\n"
"test,34_blah,blu_34,doesn't matter\n"
"test,56_foo,bar,nevermind")
subst = "$1_$2,"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.