use strict;
my $str = 'test,12_blah,blubb,anything
test,34_blah,blu_34,doesn\'t matter
test,56_foo,bar,nevermind';
my $regex = qr/^([^,]*,(\d\d)_[^,]*,[^,]*)(?<!_\d\d),/msp;
my $subst = '$1_$2,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";