using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.{0,8})?w(.{0,8})?s";
string substitution = @"";
string input = @"tahbAwgubsuregbbu";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}