use strict;
my $str = 'tahbAwgubsuregbbu';
my $regex = qr/(.{0,8})?w(.{0,8})?s/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";