const regex = /(.{0,8})?w(.{0,8})?s/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.{0,8})?w(.{0,8})?s', '')
const str = `tahbAwgubsuregbbu`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);