import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(\\w\\w:)|(\\w:)) (.*\\n?)\\1?\\2?";
final String string = "a: 1, 2, 3\n"
+ "a: a, b, v\n"
+ "b: 5, 6, 7\n"
+ "b: 10, 1543, 1345\n"
+ "b: e, fe, sdf\n"
+ "cd: asdf, asdfas dfasdfa,asdfasdfa,afdsfa sdf\n"
+ "e1: asdfas, dafasd, adsf, asdfasd\n"
+ "e1: 1, 3, 2\n"
+ "e1: 9, 8, 7, 6\n";
final String subst = "\\t\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}