const regex = /(?<=(\w\w:)|(\w:)) (.*\n?)\1?\2?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(\\w\\w:)|(\\w:)) (.*\\n?)\\1?\\2?', 'g')
const str = `a: 1, 2, 3
a: a, b, v
b: 5, 6, 7
b: 10, 1543, 1345
b: e, fe, sdf
cd: asdf, asdfas dfasdfa,asdfasdfa,afdsfa sdf
e1: asdfas, dafasd, adsf, asdfasd
e1: 1, 3, 2
e1: 9, 8, 7, 6
`;
const subst = `\t\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);