# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=(\w\w:)|(\w:)) (.*\n?)\1?\2?"
test_str = ("a: 1, 2, 3\n"
"a: a, b, v\n"
"b: 5, 6, 7\n"
"b: 10, 1543, 1345\n"
"b: e, fe, sdf\n"
"cd: asdf, asdfas dfasdfa,asdfasdfa,afdsfa sdf\n"
"e1: asdfas, dafasd, adsf, asdfasd\n"
"e1: 1, 3, 2\n"
"e1: 9, 8, 7, 6\n")
subst = "\\t\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.