use strict;
my $str = 'a: 1, 2, 3
a: a, b, v
b: 5, 6, 7
b: 10, 1543, 1345
b: e, fe, sdf
cd: asdf, asdfas dfasdfa,asdfasdfa,afdsfa sdf
e1: asdfas, dafasd, adsf, asdfasd
e1: 1, 3, 2
e1: 9, 8, 7, 6
';
my $regex = qr/(?<=(\w\w:)|(\w:)) (.*\n?)\1?\2?/p;
my $subst = '\\t\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";