#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Ma-h]{32}[a-zA-Z0-9=]{6}(.)[a-zA-Z0-9=]{23}\1[a-zA-Z0-9=]{39}$"
Local $sString = "BhcdbKEdGCbdCGHGaFEAEDEacaCAeDcbHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiyRCkct1hCOCkpHd" & @CRLF & _
"aCchdcdHAHdaffGGbbhFcKAKACfbcGKDM18dMveVcaRXfK6aD7RoYKRVflMwPiedD26TYWjCcWvwS1CPfWkqPZrbDWZojiqbtaZAMO" & @CRLF & _
"DaeechbAEGcAhHDKKEFFGDDdcDbFhGbGHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiUR1Rce1hIOCkpHd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")