const regex = /^[A-Ma-h]{32}[a-zA-Z0-9=]{6}(.)[a-zA-Z0-9=]{23}\1[a-zA-Z0-9=]{39}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Ma-h]{32}[a-zA-Z0-9=]{6}(.)[a-zA-Z0-9=]{23}\\1[a-zA-Z0-9=]{39}$', 'gm')
const str = `BhcdbKEdGCbdCGHGaFEAEDEacaCAeDcbHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiyRCkct1hCOCkpHd
aCchdcdHAHdaffGGbbhFcKAKACfbcGKDM18dMveVcaRXfK6aD7RoYKRVflMwPiedD26TYWjCcWvwS1CPfWkqPZrbDWZojiqbtaZAMO
DaeechbAEGcAhHDKKEFFGDDdcDbFhGbGHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiUR1Rce1hIOCkpHd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}