re = /^[A-Ma-h]{32}[a-zA-Z0-9=]{6}(.)[a-zA-Z0-9=]{23}\1[a-zA-Z0-9=]{39}$/m
str = 'BhcdbKEdGCbdCGHGaFEAEDEacaCAeDcbHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiyRCkct1hCOCkpHd
aCchdcdHAHdaffGGbbhFcKAKACfbcGKDM18dMveVcaRXfK6aD7RoYKRVflMwPiedD26TYWjCcWvwS1CPfWkqPZrbDWZojiqbtaZAMO
DaeechbAEGcAhHDKKEFFGDDdcDbFhGbGHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiUR1Rce1hIOCkpHd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end