use strict;
my $str = 'BhcdbKEdGCbdCGHGaFEAEDEacaCAeDcbHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiyRCkct1hCOCkpHd
aCchdcdHAHdaffGGbbhFcKAKACfbcGKDM18dMveVcaRXfK6aD7RoYKRVflMwPiedD26TYWjCcWvwS1CPfWkqPZrbDWZojiqbtaZAMO
DaeechbAEGcAhHDKKEFFGDDdcDbFhGbGHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiUR1Rce1hIOCkpHd
';
my $regex = qr/^[A-Ma-h]{32}[a-zA-Z0-9=]{6}(.)[a-zA-Z0-9=]{23}\1[a-zA-Z0-9=]{39}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}