# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Ma-h]{32}[a-zA-Z0-9=]{6}(.)[a-zA-Z0-9=]{23}\1[a-zA-Z0-9=]{39}$"
test_str = ("BhcdbKEdGCbdCGHGaFEAEDEacaCAeDcbHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiyRCkct1hCOCkpHd\n"
"aCchdcdHAHdaffGGbbhFcKAKACfbcGKDM18dMveVcaRXfK6aD7RoYKRVflMwPiedD26TYWjCcWvwS1CPfWkqPZrbDWZojiqbtaZAMO\n"
"DaeechbAEGcAhHDKKEFFGDDdcDbFhGbGHvJoHw=urCPsFfGCeYPIzfPuFNHB61=oeaGMzlRmrlwBtvm6Fl0V6kiUR1Rce1hIOCkpHd\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.