using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]+href=[""']([^>]*(?:test|aa)[^>]*)[""'][^>]*>(.*)<\/a>";
string input = @"<A href=""rwrwetestrwe"">rwewrtestewe</a> <a href='rwrwtestewre'>wrewreaa2rwe</a> <a href=""rwrwewre"">notvalid</a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}