$re = '/<a[^>]+href=["\']([^>]*(?:test|aa)[^>]*)["\'][^>]*>(.*)<\/a>/ismU';
$str = '<A href="rwrwetestrwe">rwewrtestewe</a> <a href=\'rwrwtestewre\'>wrewreaa2rwe</a> <a href="rwrwewre">notvalid</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);