re = /<a[^>]+href=["']([^>]*(?:test|aa)[^>]*)["'][^>]*>(.*)<\/a>/im
str = '<A href="rwrwetestrwe">rwewrtestewe</a> <a href=\'rwrwtestewre\'>wrewreaa2rwe</a> <a href="rwrwewre">notvalid</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end