// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ismU)<a[^>]+href=["']([^>]*(?:test|aa)[^>]*)["'][^>]*>(.*)<\/a>"#).unwrap();
let string = "<A href=\"rwrwetestrwe\">rwewrtestewe</a> <a href='rwrwtestewre'>wrewreaa2rwe</a> <a href=\"rwrwewre\">notvalid</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}