package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ismU)<a[^>]+href=["']([^>]*(?:test|aa)[^>]*)["'][^>]*>(.*)<\/a>`)
var str = `<A href="rwrwetestrwe">rwewrtestewe</a> <a href='rwrwtestewre'>wrewreaa2rwe</a> <a href="rwrwewre">notvalid</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}