#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\((088|089)\)|(088|089))\d{7}$"
Local $sString = "(089)2345672" & @CRLF & _
"0881234567" & @CRLF & _
"(089)2345672" & @CRLF & _
"088" & @CRLF & _
"089123" & @CRLF & _
"0891(23)4567" & @CRLF & _
"(0812)34567" & @CRLF & _
"089)1234567" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")