import re
regex = re.compile(r"^(\((088|089)\)|(088|089))\d{7}$", flags=re.MULTILINE)
test_str = ("(089)2345672\n"
"0881234567\n"
"(089)2345672\n"
"088\n"
"089123\n"
"0891(23)4567\n"
"(0812)34567\n"
"089)1234567\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")