package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\((088|089)\)|(088|089))\d{7}$`)
var str = `(089)2345672
0881234567
(089)2345672
088
089123
0891(23)4567
(0812)34567
089)1234567
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}