const regex = /^(\((088|089)\)|(088|089))\d{7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\((088|089)\\)|(088|089))\\d{7}$', 'gm')
const str = `(089)2345672
0881234567
(089)2345672
088
089123
0891(23)4567
(0812)34567
089)1234567
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}