$re = '/^(\((088|089)\)|(088|089))\d{7}$/m';
$str = '(089)2345672
0881234567
(089)2345672
088
089123
0891(23)4567
(0812)34567
089)1234567
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);