#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(ssh-rsa) (?!toto)"
Local $sString = "ssh-rsa"
Local $sSubst = "\1 tata"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)