$re = '/^(ssh-rsa) (?!toto)/';
$str = 'ssh-rsa';
$subst = "\1 tata";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;