const regex = new RegExp('^(ssh-rsa) (?!toto)', '')
const str = `ssh-rsa`;
const subst = `\1 tata`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);