using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(ssh-rsa) (?!toto)";
string substitution = @"\1 tata";
string input = @"ssh-rsa";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}