#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\p{L}]+\s[\p{L}]+"
Local $sString = "Firstname Surname" & @CRLF & _
"Fírstnámé Súrnámé" & @CRLF & _
"Firstname Surname000" & @CRLF & _
"Fírstnámé Súrnámé000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")