package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\p{L}]+\s[\p{L}]+`)
var str = `Firstname Surname
Fírstnámé Súrnámé
Firstname Surname000
Fírstnámé Súrnámé000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}