using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\p{L}]+\s[\p{L}]+";
string input = @"Firstname Surname
Fírstnámé Súrnámé
Firstname Surname000
Fírstnámé Súrnámé000";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}