$re = '/[\p{L}]+\s[\p{L}]+/';
$str = 'Firstname Surname
Fírstnámé Súrnámé
Firstname Surname000
Fírstnámé Súrnámé000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);