re = /[\p{L}]+\s[\p{L}]+/
str = 'Firstname Surname
Fírstnámé Súrnámé
Firstname Surname000
Fírstnámé Súrnámé000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end