#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^.;])$"
Local $sString = "Something" & @CRLF & _
"" & @CRLF & _
"Something." & @CRLF & _
"" & @CRLF & _
"Something;" & @CRLF & _
"" & @CRLF & _
"Something "
Local $sSubst = "$1; and more to say"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)