package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^.;])$`)
var str = `Something
Something.
Something;
Something `
var substitution = "$1; and more to say"
fmt.Println(re.ReplaceAllString(str, substitution))
}