const regex = /([^.;])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^.;])$', 'gm')
const str = `Something
Something.
Something;
Something `;
const subst = `$1; and more to say`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);