import re
regex = re.compile(r"([^.;])$", flags=re.MULTILINE)
test_str = ("Something\n\n"
"Something.\n\n"
"Something;\n\n"
"Something ")
subst = "$1; and more to say"
result = regex.sub(subst, test_str)
if result:
print(result)