re = /([^.;])$/m
str = 'Something
Something.
Something;
Something '
subst = '$1; and more to say'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result