using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hello .+ goodbye";
string input = @"asdasd dwref ADSADSADA Hello i'm Gabi :D goodbye asd asl sodjasdji asdoija";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}