$re = '/hello .+ goodbye/i';
$str = 'asdasd dwref ADSADSADA Hello i\'m Gabi :D goodbye asd asl sodjasdji asdoija';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);