package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)hello .+ goodbye`)
var str = `asdasd dwref ADSADSADA Hello i'm Gabi :D goodbye asd asl sodjasdji asdoija`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}