const regex = new RegExp('hello .+ goodbye', 'i')
const str = `asdasd dwref ADSADSADA Hello i'm Gabi :D goodbye asd asl sodjasdji asdoija`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}