re = /hello .+ goodbye/i
str = 'asdasd dwref ADSADSADA Hello i\'m Gabi :D goodbye asd asl sodjasdji asdoija'
# Print the match result
str.match(re) do |match|
puts match.to_s
end