#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[Jj*][u*][m*][p*](?:[i*][n*][g*]|[e*][d*])?"
Local $sString = "Jump" & @CRLF & _
"J**p" & @CRLF & _
"J*m*" & @CRLF & _
"J***" & @CRLF & _
"***p" & @CRLF & _
"J***ing" & @CRLF & _
"J***ed" & @CRLF & _
"****ed" & @CRLF & _
"*****d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")