const regex = new RegExp('[Jj*][u*][m*][p*](?:[i*][n*][g*]|[e*][d*])?', 'g')
const str = `Jump
J**p
J*m*
J***
***p
J***ing
J***ed
****ed
*****d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}