import re
regex = re.compile(r"[Jj*][u*][m*][p*](?:[i*][n*][g*]|[e*][d*])?")
test_str = ("Jump\n"
"J**p\n"
"J*m*\n"
"J***\n"
"***p\n"
"J***ing\n"
"J***ed\n"
"****ed\n"
"*****d")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")