// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[Jj*][u*][m*][p*](?:[i*][n*][g*]|[e*][d*])?").unwrap();
let string = "Jump
J**p
J*m*
J***
***p
J***ing
J***ed
****ed
*****d";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}