re = /[Jj*][u*][m*][p*](?:[i*][n*][g*]|[e*][d*])?/
str = 'Jump
J**p
J*m*
J***
***p
J***ing
J***ed
****ed
*****d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end